Apache : comment gérer l'erreur "AH01630: client denied by server configuration" ?

L'erreur se produit notamment si vous mettez à jour votre serveur en version 2.4 sans avoir modifié le fichier de configuration au préalable.

Si vous utilisez les mauvaises directives de configuration pour votre serveur Apache, le message d'erreur suivant s'affiche lors de son démarrage :

AH01630: client denied by server configuration

Cette erreur se produit notamment si vous mettez à jour votre serveur en version 2.4 sans avoir modifié le fichier de configuration au préalable.

Dans la version 2.2, les autorisations d'accès aux données étaient gérées avec les directives "order", "allow", "deny" et "satisfy". Pour autoriser l'accès à tout le monde sur un répertoire, il faut saisir les lignes suivantes :

Order allow,deny
Allow from all

Depuis la version 2.4, les accès sont gérés par le nouveau module mod_authz_host, qui gère également tous les autres contrôles d'autorisation. Les nouvelles directives à utiliser sont "Require any", "Require all" et "Require none". Pour autoriser l'accès à tout le monde pour un répertoire, une seule ligne est nécessaire :

Require all granted

Pour obtenir plus d'informations sur les autres éléments ayant été modifiés lors de la mise à jour d'Apache, ainsi que d'autres exemples pour utiliser le nouveau système de contrôle d'accès, reportez-vous au guide de migration d'Apache.

Divers

Annonces Google