Passage à Java 1.5 pour Maven

Dans sa version 2.2, l'outil de build Maven introduit un rehaussement de la version minimale de Java à 1.5 - au lieu de la version 1.4 utilisée auparavant. Une évolution qui est susceptible de poser quelques problèmes aux projets amorcés avec Java 1.4. Le projet a prévu une solution qu'il explique dans un guide. Un autre problème évoqué par Apache dans sa note de lancement concerne les exécutions avec des id “default-phase”.

Apache